Commit 47e1cb1f authored by Stefan Hajnoczi's avatar Stefan Hajnoczi

scripts: add argparse module for Python 2.6 compatibility

The minimum Python version supported by QEMU is 2.6.  The argparse
standard library module was only added in Python 2.7.  Many scripts
would like to use argparse because it supports command-line
sub-commands.

This patch adds argparse.  See the top of argparse.py for details.
Suggested-by: 's avatarDaniel P. Berrange <berrange@redhat.com>
Signed-off-by: 's avatarStefan Hajnoczi <stefanha@redhat.com>
Acked-by: 's avatarJohn Snow <jsnow@redhat.com>
Message-id: 20170825155732.15665-2-stefanha@redhat.com
Signed-off-by: 's avatarStefan Hajnoczi <stefanha@redhat.com>
parent c3a8fe33
This diff is collapsed.
This diff is collapsed.
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment