.travis.yml 6.65 KB
Newer Older
1
sudo: false
2 3
language: c
python:
4
  - "2.6"
5 6
compiler:
  - gcc
7
cache: ccache
8 9 10
addons:
  apt:
    packages:
11
      # Build dependencies
12 13 14 15
      - libaio-dev
      - libattr1-dev
      - libbrlapi-dev
      - libcap-ng-dev
16
      - libgcc-4.8-dev
17 18 19 20 21
      - libgnutls-dev
      - libgtk-3-dev
      - libiscsi-dev
      - liblttng-ust-dev
      - libncurses5-dev
22
      - libnfs-dev
23 24 25 26 27 28 29 30 31 32 33 34 35 36 37
      - libnss3-dev
      - libpixman-1-dev
      - libpng12-dev
      - librados-dev
      - libsdl1.2-dev
      - libseccomp-dev
      - libspice-protocol-dev
      - libspice-server-dev
      - libssh2-1-dev
      - liburcu-dev
      - libusb-1.0-0-dev
      - libvte-2.90-dev
      - sparse
      - uuid-dev

38 39 40
# The channel name "irc.oftc.net#qemu" is encrypted against qemu/qemu
# to prevent IRC notifications from forks. This was created using:
# $ travis encrypt -r "qemu/qemu" "irc.oftc.net#qemu"
41 42 43
notifications:
  irc:
    channels:
44
      - secure: "F7GDRgjuOo5IUyRLqSkmDL7kvdU4UcH3Lm/W2db2JnDHTGCqgEdaYEYKciyCLZ57vOTsTsOgesN8iUT7hNHBd1KWKjZe9KDTZWppWRYVwAwQMzVeSOsbbU4tRoJ6Pp+3qhH1Z0eGYR9ZgKYAoTumDFgSAYRp4IscKS8jkoedOqM="
45 46
    on_success: change
    on_failure: always
47 48
env:
  global:
49
    - TEST_CMD="make check"
50
    - MAKEFLAGS="-j3"
51
  matrix:
52 53
    - CONFIG="--disable-system"
    - CONFIG="--disable-user"
54
    - CONFIG="--enable-debug --enable-debug-tcg"
55
    - CONFIG="--disable-linux-aio --disable-cap-ng --disable-attr --disable-brlapi --disable-uuid --disable-libusb --disable-user"
56 57 58
    - CONFIG="--enable-modules --disable-linux-user"
    - CONFIG="--with-coroutine=ucontext --disable-linux-user"
    - CONFIG="--with-coroutine=sigaltstack --disable-linux-user"
59 60 61
git:
  # we want to do this ourselves
  submodules: false
62
before_install:
63 64
  - if [ "$TRAVIS_OS_NAME" == "osx" ]; then brew update ; fi
  - if [ "$TRAVIS_OS_NAME" == "osx" ]; then brew install libffi gettext glib pixman ; fi
65
  - wget -O - http://people.linaro.org/~alex.bennee/qemu-submodule-git-seed.tar.xz | tar -xvJ
66
  - git submodule update --init --recursive
67
before_script:
68
  - ./configure ${CONFIG}
69
script:
70
  - make ${MAKEFLAGS} && ${TEST_CMD}
71 72
matrix:
  include:
73 74 75
    # Test with CLang for compile portability
    - env: CONFIG=""
      compiler: clang
76 77
    # gprof/gcov are GCC features
    - env: CONFIG="--enable-gprof --enable-gcov --disable-pie"
78
      compiler: gcc
79 80
    # We manually include builds which we disable "make check" for
    - env: CONFIG="--enable-debug --enable-tcg-interpreter"
81
           TEST_CMD=""
82
      compiler: gcc
83
    - env: CONFIG="--enable-trace-backends=simple"
84
           TEST_CMD=""
85
      compiler: gcc
86
    - env: CONFIG="--enable-trace-backends=ftrace"
87
           TEST_CMD=""
88
      compiler: gcc
89
    - env: CONFIG="--enable-trace-backends=ust"
90 91
           TEST_CMD=""
      compiler: gcc
Paolo Bonzini's avatar
Paolo Bonzini committed
92 93 94
    - env: CONFIG="--disable-tcg"
           TEST_CMD=""
      compiler: gcc
95 96 97
    - env: CONFIG=""
      os: osx
      compiler: clang
98 99 100 101 102 103 104 105 106 107 108 109 110
    # Plain Trusty System Build
    - env: CONFIG="--disable-linux-user"
      sudo: required
      addons:
      dist: trusty
      compiler: gcc
      before_install:
        - sudo apt-get update -qq
        - sudo apt-get build-dep -qq qemu
        - wget -O - http://people.linaro.org/~alex.bennee/qemu-submodule-git-seed.tar.xz | tar -xvJ
        - git submodule update --init --recursive
    # Plain Trusty Linux User Build
    - env: CONFIG="--disable-system"
111 112 113 114 115 116 117 118 119
      sudo: required
      addons:
      dist: trusty
      compiler: gcc
      before_install:
        - sudo apt-get update -qq
        - sudo apt-get build-dep -qq qemu
        - wget -O - http://people.linaro.org/~alex.bennee/qemu-submodule-git-seed.tar.xz | tar -xvJ
        - git submodule update --init --recursive
120
    # Trusty System build with latest stable clang & python 3.0
121 122 123 124 125
    - sudo: required
      addons:
      dist: trusty
      language: generic
      compiler: none
126 127
      python:
        - "3.0"
128 129
      env:
        - COMPILER_NAME=clang CXX=clang++-3.9 CC=clang-3.9
130
        - CONFIG="--disable-linux-user --cc=clang-3.9 --cxx=clang++-3.9 --python=/usr/bin/python3"
131 132 133 134 135 136 137 138 139 140
      before_install:
        - wget -nv -O - http://llvm.org/apt/llvm-snapshot.gpg.key | sudo apt-key add -
        - sudo apt-add-repository -y 'deb http://llvm.org/apt/trusty llvm-toolchain-trusty-3.9 main'
        - sudo apt-get update -qq
        - sudo apt-get install -qq -y clang-3.9
        - sudo apt-get build-dep -qq qemu
        - wget -O - http://people.linaro.org/~alex.bennee/qemu-submodule-git-seed.tar.xz | tar -xvJ
        - git submodule update --init --recursive
      before_script:
        - ./configure ${CONFIG} || cat config.log
141
    # Trusty Linux User build with latest stable clang & python 3.6
142
    - sudo: required
143 144 145 146
      addons:
      dist: trusty
      language: generic
      compiler: none
147 148
      python:
        - "3.6"
149 150
      env:
        - COMPILER_NAME=clang CXX=clang++-3.9 CC=clang-3.9
151
        - CONFIG="--disable-system --cc=clang-3.9 --cxx=clang++-3.9 --python=/usr/bin/python3"
152 153 154 155 156 157 158 159 160 161
      before_install:
        - wget -nv -O - http://llvm.org/apt/llvm-snapshot.gpg.key | sudo apt-key add -
        - sudo apt-add-repository -y 'deb http://llvm.org/apt/trusty llvm-toolchain-trusty-3.9 main'
        - sudo apt-get update -qq
        - sudo apt-get install -qq -y clang-3.9
        - sudo apt-get build-dep -qq qemu
        - wget -O - http://people.linaro.org/~alex.bennee/qemu-submodule-git-seed.tar.xz | tar -xvJ
        - git submodule update --init --recursive
      before_script:
        - ./configure ${CONFIG} || cat config.log
162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200
    # Using newer GCC with sanitizers
    - addons:
        apt:
          sources:
            # PPAs for newer toolchains
            - ubuntu-toolchain-r-test
          packages:
            # Extra toolchains
            - gcc-5
            - g++-5
            # Build dependencies
            - libaio-dev
            - libattr1-dev
            - libbrlapi-dev
            - libcap-ng-dev
            - libgnutls-dev
            - libgtk-3-dev
            - libiscsi-dev
            - liblttng-ust-dev
            - libnfs-dev
            - libncurses5-dev
            - libnss3-dev
            - libpixman-1-dev
            - libpng12-dev
            - librados-dev
            - libsdl1.2-dev
            - libseccomp-dev
            - libspice-protocol-dev
            - libspice-server-dev
            - libssh2-1-dev
            - liburcu-dev
            - libusb-1.0-0-dev
            - libvte-2.90-dev
            - sparse
            - uuid-dev
      language: generic
      compiler: none
      env:
        - COMPILER_NAME=gcc CXX=g++-5 CC=gcc-5
201
        - CONFIG="--cc=gcc-5 --cxx=g++-5 --disable-pie --disable-linux-user"
202 203 204
        - TEST_CMD=""
      before_script:
        - ./configure ${CONFIG} --extra-cflags="-g3 -O0 -fsanitize=thread -fuse-ld=gold" || cat config.log